缙哥哥的博客
与你分享我的点点滴滴生活

Linux/Deepin深度终端curl、npm、git安装指令

鉴于深度系统Deepin中的Shadowsocks-Qt5不支持协议和混淆,又没有SSR客户端,没办法,缙哥哥只能用命令来解决,结果发现基础npmcurl功能都没有,还是先安装基础吧。

curl安装指令

sudo apt-get install curl libcurl3 libcurl3-dev php5-curl

npm安装指令

npm需要分两步走,curl是前提。首先升级软件源,安装nodejs

sudo apt-get update
sudo apt-get install nodejs

安装npm

sudo apt-get install npm
deepin系统安装curl和npm功能截图

deepin系统安装curl和npm功能截图

git安装指令

apt-get update
apt-get install git -y

这里值得一提的是,deepin深度系统需要root权限才能升级或安装git,需要配合下方指令,注意大小写:

sudo -s -H

在此做个记录,以免自己忘记,同样可以给小伙伴们查阅。deepin深度终端还是不错的,至少TM是中文。

转载请注明来源及链接:缙哥哥 » Linux/Deepin深度终端curl、npm、git安装指令
分享到: 更多 (0)