缙哥哥的博客
与你分享我的点点滴滴生活

使用 WordPress 建站不能使用阿里云虚拟主机

在今年的3.21,缙哥哥因为WordPress低于5.*版本漏洞而更新了《旧WordPress出现跨站点脚本漏洞,建议尽快升级至5.1.1版本》,在文中提到了“在2019年4月,我们将最低PHP版本要求提高到5.6,最低MySQL版本要求提高到5.5”……然而,今天,缙哥哥就接到了这么个单子

注册邮件密码不显示、文章点赞无效、网站统计数据出错、外链go跳转异常

经过排查修改之后发现,起罪魁祸首主要是因为数据库版本过低导致。所以缙哥哥在这里强调:“WordPress建站不能使用阿里云虚拟主机”。

阿里云虚拟主机MySQL版本过低

通过小伙伴的管理后台发现,阿里云的数据库类型只有 MySQL 5.1.73 这一个选项,而现在 WordPress 对 MySQL 的最低要求都需要 5.5 以上版本。

接下来通过查询阿里云官方说明页面,发现所有的虚拟主机版本,在 Linux 系统下均只有 MySQL 5.1 这一个版本。

所以缙哥哥在这里再次强调:“WordPress建站不能使用阿里云虚拟主机”。如果你想要一个不需要管理服务器的虚拟主机,可以考虑托管到缙哥哥的服务器上,缙哥哥已经对WordPress所需的环境进行了优化加速,相比于阿里云的虚拟主机,绝对性能更强。《ECS/VPS 云服务器、网站运维托管服务

历史上的今天:

  1. 2018年:  《会声会影 2018 v21.2.0.113 中文旗舰破解版附常见问题》- 作者:缙哥哥(60)
  2. 2018年:  《Office 2016 - 64位Volume License官方正式版,附一键激活授权》- 作者:缙哥哥(6)
  3. 2016年:  《手脚出汗或因脾胃虚弱》- 作者:缙哥哥(0)
赞(4) 打赏
转载请注明来源及链接:缙哥哥 » 使用 WordPress 建站不能使用阿里云虚拟主机
分享到: 更多 (0)

评论 6

评论前必须登录!

 

  1. #3

    我的万网免费虚拟主机续费了好多年还没过期!

    ouxiaopi2周前 (04-10)
  2. #2

    现在的云主机已经当虚拟主机在卖了。

  3. #1

    使用老版本,一切都解决了。

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏